尝试在Android Studio中打开项目文件时出现以下错误:

“在此构建中使用了已弃用的Gradle功能,使其与Gradle 6.0不相容。”

我在这里做错了什么,或者是书项目文件真的真的过时了吗?

试图再次这样做并得到这个,同样;

未检测到的不受支持的模块:以下模块不支持编译:TimeFighter,App。不幸的是,您不能在一个项目中拥有非GEDLED Java模块和Android-Gradle模块。

嘿,欢迎来到论坛。 :微笑:

我很遗憾听到你在第一章有问题。你是对的,关于超出日期的示例项目文件。我们计划在解决此问题上进行更新,尽管目前我没有有关日期的详细信息。

同时。我在Android Studio打开了第1章项目并设法才能建立它。诀窍是确保更新Android Gradle Plugin。

Android Studio应警告您,如果项目使用旧版本的插件。它看起来像这样:

当您看到弹出窗口时,单击 更新 按钮。 Android Studio将完成更新项目并建立它的所有努力工作。

Android Studio完成后,再次运行该项目。该应用程序现在应该构建。

请让我知道你是如何进入的。如果上面的指示没有帮助,我们可以尝试别的东西。

谢谢,

达里尔